× KISS International Help Forum. English language, please.

KISS GooSence causes 500 error

Mehr
31 Mär 2017 19:35 #6992

Hello,

I am currently running a Joomla 2.5 (most recent version) website and am preparing it for migrating to a Joomla 3. I have been using the KissGoogleAdsense module for quite some time, but wanted to update now to the latest version - Kiss GooSence - to make sure it will be compatible with Joomla 3.

So I installed it (I didn't uninstall the old version yet, it's still on there too), but when I configure it and enable the module, then all pages that are supposed to show the google ads are giving a 500 error. As soon as I disable the module, the webpages work normally again.

Everything should be configured correctly, as I put in the exact same settings as in the old module.

What can I do to fix this?

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
01 Apr 2017 10:36 #6993

Hi,
as you can see here , the GooSence module is working with the most recent Joomla version 3.6.x (you must be logged out in order to see adverts as on this website, ads are displayed to anonymous users only).

If you encounter an error 500 (which means 'Internal Server Error'), something is probably interacting with the server redirection. This eror also occurs if your PHP or Mysql version is incorrect. Please also check for other components which could influence advertising displays, such as popup blockers etc.


Ob ein Glas halb voll oder halb leer ist, ist mir egal. Hauptsache meine Zähne passen rein.
No matter whether a glass is half full or half empty - as long as my teeth fit in.
Letzte Änderung: 01 Apr 2017 10:40 von DocChicago.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
01 Apr 2017 11:28 #6994

Thanks for your response.

I am (for now) using Joomla 2.5, is that an issue for the module?

The Database Version is 5.5.36-34.2-648.squeeze
The PHP Version is 5.3.28-1

Could any of this be the problem? I am aware that this is an old version of PHP, but my provider doesn't want to update it because they are phasing out the virtual server I'm on while they apparently don't have new ones available to move to :(

I do have Adblock Plus but I disabled it for testing purposes. Even so, having an adblocker enabled shouldn't break the entire site, only hide the ads themselves. The older version never gave any issues.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
04 Apr 2017 09:38 #6995

Usually the module causes no issues with Joomla 2.5 or Joomla 3.x. We didn't make any changes to the new module except for the multi-user extension.

For Joomla 2.5 and 3.x, a PHP version of 5.6 is recommended. The least required version is 5.3, however with this version it cannot be guaranteed that all components will work flawlessly. We cannot exclude problems with this version on certain server constellations. The database version of 5.5.3 should cause no problems.

See Joomla Technical Requirements


Ob ein Glas halb voll oder halb leer ist, ist mir egal. Hauptsache meine Zähne passen rein.
No matter whether a glass is half full or half empty - as long as my teeth fit in.
Letzte Änderung: 04 Apr 2017 09:41 von DocChicago.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
22 Aug 2017 20:40 #7021

Hello,

I know it's been awhile, but I was finally able to have my website moved to a new server with an up-to-date php version. Recently I also upgraded to Joomla 3 succesfully.

I tried installing Kiss GooSence again. It no longer gives me a 500 error or any other errors, but it also doesn't display any google ads. It simply displays nothing (no blank area either where the google ads are supposed to be), but the browser keeps trying to load something for a long time.

What can the cause of this problem be?
I have double checked the Publisher ID and it's definitely correct.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
24 Aug 2017 12:01 #7022

Since we have nothing changed on the module and it works flawlessly on many Joomla installation, I would guess that it's a PHP or server issue. Try PHP 7.0 rather than 7.1 and allow your server to access remote websites. e.g. PHP setting 'allow_url_fopen = true'.

Have you already tried to set the Joomla error messages to 'Maximum' or 'Development'? Maybe it reports some more information. Also try to get some information from your browser (Javascript logs etc.)


Ob ein Glas halb voll oder halb leer ist, ist mir egal. Hauptsache meine Zähne passen rein.
No matter whether a glass is half full or half empty - as long as my teeth fit in.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Powered by Kunena Forum
Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklären Sie sich damit einverstanden, dass wir Cookies verwenden.
Weitere Informationen